Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
Satelite L300D- Black screen at start-up
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Pages: 1 - Last Post: 18-Sep-2012 13:50 Last Post By: sanajbg
Fauxkingphil

Posts: 3
Registered: 12/08/12
Satelite L300D- Black screen at start-up
Posted: 12-Aug-2012 20:43
 
  Click to reply to this thread Reply
Hi People,

Any help would be greatly appreciated.

I have a Toshiba Satelite L300D-11V. I dont know what happens but now when ever I try to power on I just get a black screen, a power light and NO HDD activity.

From what I have read I suspect I need to flash the Bios, but I seem to be struggling with this.

Anybody sucesfully flashed? Any tips??
assex

Posts: 2,129
Registered: 25/09/09
Re: Satelite L300D- Black screen at start-up
Posted: 12-Aug-2012 22:27   in response to: Fauxkingphil in response to: Fauxkingphil
 
  Click to reply to this thread Reply
For me it sounds like screwed up BIOS?
Have you tried to update BIOS last days?
Fauxkingphil

Posts: 3
Registered: 12/08/12
Re: Satelite L300D- Black screen at start-up
Posted: 13-Aug-2012 20:13   in response to: Fauxkingphil in response to: Fauxkingphil
 
  Click to reply to this thread Reply
Yes I thinking same too.

Any ideas how to flash the BIOS whenit does not show any signs of life after switch on???
sanajbg

Posts: 1
Registered: 18/09/12
Re: Satelite L300D- Black screen at start-up
Posted: 18-Sep-2012 11:36   in response to: Fauxkingphil in response to: Fauxkingphil
 
  Click to reply to this thread Reply
i have a similar issue with Sat lite L500. When i turn on the laptop complete screen back.
i fixed the problem like this.

Removed the battery. Press and hold the Power button for more than 30 sec. and used an ac adapter to turn on the laptop.It really worked for me.

Now it is booting without any problem.i don't know if the same will work on other models.
If this not working you can try the same procedure with battery inserted.
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software