Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
Satellite L300 - Unknown devices in device manager
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 19 - Pages: 2 [ Previous | 1 2 ] - Last Post: 30-Apr-2012 14:15 Last Post By: venkat09
venkat09

Posts: 12
Registered: 25/04/12
Re: Satellite L300 - Unknown devices in device manager
Posted: 26-Apr-2012 15:50   in response to: venkat09 in response to: venkat09
 
  Click to reply to this thread Reply
can any one still help me with some other way with out repair or installing vista?
mrnobita

Posts: 1
Registered: 29/04/12
Re: Satellite L300 - Unknown devices in device manager
Posted: 29-Apr-2012 06:01   in response to: venkat09 in response to: venkat09
 
  Click to reply to this thread Reply
Hello,

I had the same problem with my Toshiba laptop , and i finally found the drivers by using DriverIdentifier, it will scan your device and give you a list of available drivers for your laptops.

I hope it help.
venkat09

Posts: 12
Registered: 25/04/12
Re: Satellite L300 - Unknown devices in device manager
Posted: 30-Apr-2012 11:44   in response to: mrnobita in response to: mrnobita
 
  Click to reply to this thread Reply
Thanks.... i know the device specification by its vendor and device and i try to download the specific device driver and install the driver but it abort the installation or if i uninstall this Unknown device from device manager and install that new driver it install successfully but when i scan for hardware change or restart my system it show the error Unknown device or system detect the drive for ur device but problem in installing the new drive.... then it will show like unknown device in device manager

any solution?
Tonny

Posts: 3,697
Registered: 21/09/09
Re: Satellite L300 - Unknown devices in device manager
Posted: 30-Apr-2012 13:40   in response to: venkat09 in response to: venkat09
 
  Click to reply to this thread Reply
>venkat09
I see that many workarounds have been posted here and no one was able to resolve this… I think the users here are right: looks like the system issue.
Before waiting days and searching for other possible solutions, why you don’t try the recovery disk…of course it’s painful to back up the data before doing this but it looks like it would be the fastest solution.
venkat09

Posts: 12
Registered: 25/04/12
Re: Satellite L300 - Unknown devices in device manager
Posted: 30-Apr-2012 14:15   in response to: Tonny in response to: Tonny
 
  Click to reply to this thread Reply
thanks for ur reply...i dont like to disturb my OS as it dont have any prob for long time...... it seem like some of the drive what i installed have prob in incompatibility issue.... with intel and Toshiba and Windows any one of this have prob so i think i can wait till one of this company will come with good solution soon.... and update the software......
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software