Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
Satellite C650 USB ports does not work
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
Thread Locked This thread is locked - replies are not allowed.


This question was marked as assumed answered by a moderator.


Permlink Replies: 11 - Pages: 1 - Last Post: 20-Mar-2012 16:56 Last Post By: colino
1filantrop1

Posts: 2
Registered: 02/02/12
Satellite C650 USB ports does not work
Posted: 02-Feb-2012 17:04
 
Hello,

I have trouble with me notebbok C650. From yesterday USB ports does not work after connected USB key, SD card or some.
Now I do not know whether it is a hardware or software error.
I tried to restore the system, change USB drivers, perform PC maintenance, check the antivirus, but nothing did not work.

I advertise laptop?

Thank´s for more info...
MasterG

Posts: 2,902
Registered: 21/09/09
Re: Satellite C650 USB ports does not work
Posted: 03-Feb-2012 08:42   in response to: 1filantrop1 in response to: 1filantrop1
 
Hi

You could try to refresh the USB ports and controllers which appear in device manager.
Disconnect all USB devices and access the device manager.
Here expand the area USB controllers.
Now delete all USB Host controllers and USB root hubs from the list.
After that reboot the notebook.
Finally the Windows OS should boot up and should recognize all USB devices once again. Now connect a USB mouse and check if you could use it.
missjocarter

Posts: 1
Registered: 04/02/12
Re: Satellite C650 USB ports does not work
Posted: 04-Feb-2012 16:30   in response to: MasterG in response to: MasterG
 
Hi,

I have the exact same problem.

The two usb ports have just stopped working. Only had the laptop 5 months from argos.
I reinstalled the usb drivers in the device manager by deleting and rebooting laptop.
Nothing works.

I checked bios is enabled which it is.

Doesn't have any yellow triangles on usb in the device manager and says device is working properly.
Ive tried a range of usb devices including mouse, phone, usb sticks and nothing works.

Please help me as I need my laptop for college work :(

Jo
1filantrop1

Posts: 2
Registered: 02/02/12
Re: Satellite C650 USB ports does not work
Posted: 04-Feb-2012 19:13   in response to: MasterG in response to: MasterG
 
Hi MasterG,

Thank you for answer. I uninstall software, after Win start download new driver and soft, but still does not working.

I sent a message to the service center with a description of the problem. I got a reply that I have to claim the device.

In previous issue I read this message:

"I got a bad news for you, C650 has a little problem. It suhtsdown the USB ports to prevent over current damage, but C650 do this too early, so if I were you, I take it to an ASP for motherboard replacement.
The revisioned one works fine."

So backup all file and go to claim this device :-/
MisterX

Posts: 3,021
Registered: 21/09/09
Re: Satellite C650 USB ports does not work
Posted: 06-Feb-2012 13:28   in response to: 1filantrop1 in response to: 1filantrop1
 
Hi

I think before visiting the Toshiba service partner you should try to recover the notebook to factory settings.
Usually if there is ONLY a software problem, the recovery procedure should help ypou to sort out this issue.
Would be definitely worth a try!
chuckiestealady

Posts: 1
Registered: 18/03/12
Re: Satellite C650 USB ports does not work
Posted: 18-Mar-2012 22:38   in response to: MasterG in response to: MasterG
 
I had exactly the same problem and spent a hopeless day fiddling around with different settings, trying to solve the problem; I was just giving up hope. I checked out this thread, tried your advice and it finally worked for me. Thank you so much! :-)
colino

Posts: 4
Registered: 18/03/12
Re: Satellite C650 USB ports does not work
Posted: 18-Mar-2012 23:22   in response to: MasterG in response to: MasterG
 
Hi
I have the same problem, I only brought this laptop last week
2 days ago everything was working well ,then in the middle of doing some work my usbs stopped working
device manager showed no problems but they were dead, after rebooting 4 times they worked again,
but 3 hours later it happend again,
this time the device manager said they both had a code 10 and not working properly.
tried to look for new drivers but had no luck,
so I did a full reinstall and they worked , but the adobe reader did not install so i could not read the user guide,
after another re install i got adobe back.
but the usbs still stop working ,sometimes its straight away from boo tup or upto 3 to 4 hours.
also Mcafee screws up.
I am not happy and i am really thinking about getting a refund as it looks like this is not a one off problem.
I think that toshiba should read these and help out
anyone got a fix please ,thanks colino
PauPau

Posts: 4,540
Registered: 21/09/09
Re: Satellite C650 USB ports does not work
Posted: 19-Mar-2012 11:11   in response to: colino in response to: colino
 
Did you try this MS workaround?
Tips for solving problems with USB devices
http://windows.microsoft.com/en-US/windows-vista/Tips-for-solving-problems-with-USB-devices

Additionally i think your system is muddled up… you are talking about so many different issues: Adobe, McAfee… all this appears really strange… also the fact that the USB ports worked again after system recovery means that this could be a system issue.

Check if an recover would fix this again and pay attention to software and updates which would be installed automatically…maybe one of the updates screws up the system.
colino

Posts: 4
Registered: 18/03/12
Re: Satellite C650 USB ports does not work
Posted: 19-Mar-2012 11:26   in response to: PauPau in response to: PauPau
 
Hi
thanks for the reply
sorry if I mixed everything up
1st issue is the usbs work for awhile then they die but the device manger shows them as working
after a reboot theu still do not work and the device manager shows them as not working and shows a code 10
after a roll back the usbs work again for a short time ,and the same circle starts again.
I have tried doing a roll back and not installing updates ,
not allowing any updates does not fix this problem.
doing a full recovery does not fix this problem.

turning off the computer for 30 mins does fix this problem, for awhile then here we go again no usbs
updating the bios as instructed by toshiba does not work .because the message i get is
the current system BIOS is the same version( or newer)than the version you are trying to flash so the BIOS will not change.
thanks a nd sorry colino
PauPau

Posts: 4,540
Registered: 21/09/09
Re: Satellite C650 USB ports does not work
Posted: 19-Mar-2012 12:20   in response to: colino in response to: colino
Correct
Well, what you can do is to disable the power saving for each USB port.
In device manager choose USB hubs and got to properties. Then choose last tab and here you can uncheck the option which allows disabling the device to save power.

By the way: here you can find similar thread about the similar issue:
http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=65823

It could be possible that this is an hardware problem which needs to be fixed by an technicians...
colino

Posts: 4
Registered: 18/03/12
Re: Satellite C650 USB ports does not work
Posted: 19-Mar-2012 13:51   in response to: PauPau in response to: PauPau
Helpful
Hi paul
thanks for the info and help
I will try the power off and see if that works, fingers crossed
thanks again ,,,,,,col
colino

Posts: 4
Registered: 18/03/12
Re: Satellite C650 USB ports does not work
Posted: 20-Mar-2012 16:56   in response to: colino in response to: colino
 
thanks everything works again ,,,,,,,,
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software