Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
Satellite A300D 14P invalid resolution + black screen on start
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
Thread Locked This thread is locked - replies are not allowed.


This question is answered.


Permlink Replies: 6 - Pages: 1 - Last Post: 12-Sep-2011 18:31 Last Post By: Hedghog
Hedghog

Posts: 4
Registered: 01/09/11
Satellite A300D 14P invalid resolution + black screen on start
Posted: 01-Sep-2011 23:52
 
Hello everyone.

My laptop suddenly decided that its monitor's native - and maximum - resolution is 1024x768 (actually it's 1280x800). The active area of the screen is situated in an upper left corner, while pixels below have the same colours as the bottommost active pixel of the same column and everything to the right is black.

Additionally, when notebook starts, it denies the mere existence of internal monitor. To turn it on I have to place my laptop into sleep mode and turn it on again.

This problem started when I updated Java Runtime Environtment and persisted after its uninstallation. It happens not the first time - but before I was able to restore my notebook to normal by uninstalling some software - specifically, a graphic tablet's driver. Unfortunately, I'm unsure what caused this problem the first time.

I've tried to connect an external monitor and it works just fine. I've tried to find the internal monitor in device manager window while it was black - and it wasn't listed there.

I've tried to update every possible driver, tried to disassemble the damned thing and even tried to uninstall some unneeded software at random but problem's still there. Now, I'm out of ideas and will appreciate any help.
PauPau

Posts: 4,534
Registered: 21/09/09
Re: Satellite A300D 14P invalid resolution + black screen on start
Posted: 02-Sep-2011 10:19   in response to: Hedghog in response to: Hedghog
Helpful
Hi

Try to remove the display driver from the system and after cleaning the registry install the graphic card driver once again.
To clean the registry you can use CCleaner. It’s freeware tool which cleans and removes garbage from the system.

You said that your external monitor works fine. Well, check if the internal display is set as default display and assign the right resolution to this display.

I assume you’ve got the ATI graphic chip. So the settings should be available in the ATI Catalyst
Hedghog

Posts: 4
Registered: 01/09/11
Re: Satellite A300D 14P invalid resolution + black screen on start
Posted: 02-Sep-2011 21:20   in response to: PauPau in response to: PauPau
 
Thanks for your reply.

PauPau wrote:
Try to remove the display driver from the system and after cleaning the registry install the graphic card driver once again.
To clean the registry you can use CCleaner. It’s freeware tool which cleans and removes garbage from the system.

I've already tried this before and it didn't help.

PauPau wrote:
You said that your external monitor works fine. Well, check if the internal display is set as default display and assign the right resolution to this display.

I assume you’ve got the ATI graphic chip. So the settings should be available in the ATI Catalyst

My graphic chip is ATI indeed, namely ATI Radeon HD 3200 Graphics integrated in motherboard.

The problem is that my system has no idea that the internal display is connected - up until I do the "sleep trick". Once the monitor is found it automatically becomes the default one, with only 1024x768, 1024x600 and 800x600 resolutions available (regardless of resolution set, the screen is always stretched to 1024x768 monitor pixels).
MisterX

Posts: 2,937
Registered: 21/09/09
Re: Satellite A300D 14P invalid resolution + black screen on start
Posted: 03-Sep-2011 10:03   in response to: Hedghog in response to: Hedghog
Helpful
Hi

The internal display should support the ma resolution of 1280 x 800 px.
This resolution should be available in the ATI graphic settings.
I cannot believe that this resolution is not available in the ATI settings and it’s really strange that display driver update or installation didn’t help you too.

What you can do is to check the BIOS settings and to set the display option to “auto”.
Also you should set the BIOS to default settings and should save the changes.

But the whole story sounds like system problem. Maybe the OS is muddled up or the registry… did you try to recover the notebook back to factory settings?
Hedghog

Posts: 4
Registered: 01/09/11
Re: Satellite A300D 14P invalid resolution + black screen on start
Posted: 03-Sep-2011 14:21   in response to: MisterX in response to: MisterX
 
MisterX wrote:
I cannot believe that this resolution is not available in the ATI settings and it’s really strange that display driver update or installation didn’t help you too.

It's strange indeed, but it seems like my system is absolutely positive that the monitor has no means to support 1280x800. If this problem wasn't (kinda) solved the first time, I would think it's not the system's, but the monitor's problem.

MisterX wrote:
What you can do is to check the BIOS settings and to set the display option to “auto”.
Also you should set the BIOS to default settings and should save the changes.

Tried, with no results. I'm not sure what I should see in display settings normally, but it seemed weird that I had only two choices for display: the "default" one, and LCD + analog RGB (external monitor, I think).

MisterX wrote:
But the whole story sounds like system problem. Maybe the OS is muddled up or the registry… did you try to recover the notebook back to factory settings?

No, I didn't and I'd really like not to use this option as long as possible. But it's seems like a fresh idea. I guess I should try to run my laptop under some live CD and look if it'd solve the problem.
MasterG

Posts: 2,890
Registered: 21/09/09
Re: Satellite A300D 14P invalid resolution + black screen on start
Posted: 03-Sep-2011 18:57   in response to: Hedghog in response to: Hedghog
 
But it's seems like a fresh idea. I guess I should try to run my laptop under some live CD and look if it'd solve the problem.

Yes, that’s great idea... try some live CD like Win PE or Bart PE…
Hedghog

Posts: 4
Registered: 01/09/11
Re: Satellite A300D 14P invalid resolution + black screen on start
Posted: 12-Sep-2011 18:31   in response to: Hedghog in response to: Hedghog
 
And finally, the problem is (kinda) solved and the reason is found. It turned out the ribbon between motherboard and monitor was damaged in really strange way so it wasn't obvious during disassembly.

Anyways, thanks for everyone's answers.
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software