Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
HDMI not working on Satellite L500-19Z
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 13 - Pages: 1 - Last Post: 03-Apr-2011 15:54 Last Post By: MasterG
anicholles

Posts: 20
Registered: 06/06/10
HDMI not working on Satellite L500-19Z
Posted: 02-Jan-2011 16:59
 
  Click to reply to this thread Reply
I have an L500-19Z running Windows 7. Up until yesterday the HDMI output socket was working fine.
However, now, when I plug a cable in the screen keeps goes blank and then returning to normal.
This continues for a few minutes and then when I try to output to eg a TV it shows as not connected.

Does anyone have any thoughts on what might be causing this?
Device Manager says that the device is working OK and I've checked that the driver is up to date.

I'm now stumped!
Any replies can also be directed to a.nicholles@ntlworld.com
MasterG

Posts: 2,877
Registered: 21/09/09
Re: HDMI not working on Satellite L500-19Z
Posted: 02-Jan-2011 17:06   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
Hi

Did you try the Fn + F5 option?
This switch the video output to external monitor or TV.
You have to press this several times in order to choose TV.

Set also BIOS to default settings and test it again
anicholles

Posts: 20
Registered: 06/06/10
Re: HDMI not working on Satellite L500-19Z
Posted: 02-Jan-2011 17:40   in response to: MasterG in response to: MasterG
 
  Click to reply to this thread Reply
Thanks but the Fn F5 option seems not to have any effect. Do you know how to set the BIOS back to default settings?
MasterG

Posts: 2,877
Registered: 21/09/09
Re: HDMI not working on Satellite L500-19Z
Posted: 02-Jan-2011 18:02   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
Hi

To set BIOS to default you have to access the BIOS (press F2 while booting).
In BIOS you have to press F9 (I guess but at the bottom of the BIOS page you can find the description what button is needed).
Save the changes and reboot again.

If FN buttons does not work, then you should reinstall the VAP and Flash Card Utility again.
Also the display driver update might be useful.
anicholles

Posts: 20
Registered: 06/06/10
Re: HDMI not working on Satellite L500-19Z
Posted: 02-Jan-2011 18:46   in response to: MasterG in response to: MasterG
 
  Click to reply to this thread Reply
No, it's still not working. The Fn F5 is now working OK but switching to HDMI, or extended mode, still doesn't solve the problem. I'm beginning to suspect that it's a hardware fault. Do you agree?
MasterG

Posts: 2,877
Registered: 21/09/09
Re: HDMI not working on Satellite L500-19Z
Posted: 02-Jan-2011 20:46   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
Don’t think it’s hardware issue.
Reinstall the display driver and check it again.
Otherwise you will need to test it with new clean OS.
anicholles

Posts: 20
Registered: 06/06/10
Re: HDMI not working on Satellite L500-19Z
Posted: 03-Jan-2011 19:24   in response to: MasterG in response to: MasterG
 
  Click to reply to this thread Reply
Sorry for delay - been out all day. When I open Device Manager which item contains the 'display driver'? Is it the sound, video controller which contains the HDMI line?
TwoLags

Posts: 1,058
Registered: 30/09/09
Re: HDMI not working on Satellite L500-19Z
Posted: 03-Jan-2011 20:33   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
Hey,

The display driver belongs to graphic card.

As MasterG wrote you should reinstall it. You can check the Toshiba page yourself for an update:
http://eu.computers.toshiba-europe.com > Support & Downloads

After download it, remove the old display driver from control panel > Uninstall software. Then restart your computer and install newest display driver.
anicholles

Posts: 20
Registered: 06/06/10
Re: HDMI not working on Satellite L500-19Z
Posted: 04-Jan-2011 13:44   in response to: TwoLags in response to: TwoLags
 
  Click to reply to this thread Reply
No, I tried that and it caused all sorts of problems. Windows failed to load and eventually I had to let Windows 'repair' itself and then I could run a system again.
C3PO

Posts: 1,995
Registered: 01/10/09
Re: HDMI not working on Satellite L500-19Z
Posted: 04-Jan-2011 13:58   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
Hello

Hmm... It seems that something is wrong with your Windows installation because the Toshiba drivers are pretested and from my own experience I can say that I never had any problems with these drivers.

As MasterG already wrote you should reinstall Windows from Toshiba recovery disk to test it with preinstalled software and drivers.

Check this!!!
anicholles

Posts: 20
Registered: 06/06/10
Re: HDMI not working on Satellite L500-19Z
Posted: 04-Jan-2011 15:43   in response to: C3PO in response to: C3PO
 
  Click to reply to this thread Reply
OK, will that mean reformatting my hard drive with a subsequent loss of data? If so, I'll make sure everything's backed up before doing it.

The other thing I've noticed is that I can't use System Restore. Whenever I try to restore, it fails no matter which restore point I choose.
C3PO

Posts: 1,995
Registered: 01/10/09
Re: HDMI not working on Satellite L500-19Z
Posted: 04-Jan-2011 15:57   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
Hello

If you use the Toshiba recovery disk for reinstalling Windows it will delete the whole HDD so you have to backup all important data on an external HDD for example.
anicholles

Posts: 20
Registered: 06/06/10
Re: HDMI not working on Satellite L500-19Z
Posted: 03-Apr-2011 12:06   in response to: C3PO in response to: C3PO
 
  Click to reply to this thread Reply
Since we last spoke I've had to re-install Windows because of another problem I had but it hasn't resolved the HDMI issue. I suppose it's possible that it may be a TV fault but as my laptop screen flashes on, and off, when the cable is inserted I'm inclined to believe that it's still a laptop issue. I can only think that it must be some kind of hardware issue.
MasterG

Posts: 2,877
Registered: 21/09/09
Re: HDMI not working on Satellite L500-19Z
Posted: 03-Apr-2011 15:54   in response to: anicholles in response to: anicholles
 
  Click to reply to this thread Reply
To be honest I have no idea why this is not working in your case…. In my case the procedure was very easy; connect TV and notebook with an good quality HDMI cable.
Choose the right channel on TV which belongs to the HDMI port of the TV.
Then power up the notebook. After that use FN + FN 5 in order to switch to external output. Note; you will need to press this several times to get HDMI as video output.
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software