Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
Satellite L300-1AQ - Fan not switching properly under Linux
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 17 - Pages: 2 [ 1 2 | Next ] - Last Post: 08-Dec-2009 17:15 Last Post By: tdassler Threads: [ Previous | Next ]
tdassler

Posts: 6
Registered: 10/10/09
Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 10-Oct-2009 09:31
 
  Click to reply to this thread Reply
For the L300-1AQ, the CPU fan is controlled by the BIOS. When booting the machine into Linux from cold, the fan spins at minimum like it should. But then nothing happens until the critical core temperature is reached. At this point the CPU fan jumps to max speed and stays there even when the air coming out is cold again. Then the only way to make the fan spin down again is to reboot.. The boot parameter 'acpi_osi=' has no effect.

This is not a hardware issue because the fan works well under Windows: slow and steady upward spins into states somewhere between min and max. After a few seconds slow and steady downward spins.

This could be a buggy dsdt sheet, which only affects Linux.
Dr.Lamp

Posts: 2,333
Registered: 25/09/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 14-Oct-2009 10:52   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
Problem is that Toshiba doesn’t support this notebook model for Linux and there is no available power management tool like Toshiba Power Saver for Windows.
Try to visit some Linux forum and discuss it there.

On Linux forums you will find more useful information or people who maybe use the same notebook with the same Linux distribution.
Al-eX

Posts: 486
Registered: 19/10/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 21-Oct-2009 15:51   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
hi tdassler
try to use boot options li­ke "noacpi" maybe this will work...
problem is that your distribution dont have / loads the correct module to control the fan.
check if the chipset is supported by your distribution - some modules need to be loaded at boottime like "fan" "termal" and so on.
but as long as toshiba wont support linux on this machine you have to look for a solution in forums which deal with linux issius on win-hardware.
sunrider

Posts: 17
Registered: 01/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 11-Nov-2009 21:19   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
Any progress on this issue ?
I've the same one with my L505 Toshiba....

Message was edited by: sunrider
cxx

Posts: 2
Registered: 15/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 15-Nov-2009 23:28   in response to: sunrider in response to: sunrider
 
  Click to reply to this thread Reply
Hey there,

I just found a solution on that issue.

The omnibook-module from http://sourceforge.net/projects/omnibook/ actually does the trick.

Just open a terminal, become root and enter the following commands:

  1. cd /usr/local/src
  2. wget http://downloads.sourceforge.net/project/omnibook/omnibook%20kernel%20module/2.20070211/omnibook-2.20070211.tar.gz?use_mirror=sunet
  3. tar xvfz omnibook*
  4. cd omnibook
  5. make
  6. make install

Now the module is installed, we just need to activate it:

  1. depmod -a
  2. modprobe omnibook ectype=11

After issuing that command fan-control is working.

  1. cat "omnibook ectype=11">>/etc/modules

And this causes the module to be loaded on boot. This last step depends on your distribution, this may be set somewhere else if you don't use a debian-based one. You surely need the appropriate kernel-sources for you your distribution and a compiler for installing the module - on debian or similar installing the packages "linux-headers-2.6-your running kernel" and "build-essential" should be enough.
tdassler

Posts: 6
Registered: 10/10/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 17-Nov-2009 18:50   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
Thanks for the advice. The omnibook module does not compile, so I need to fiddle with it. But the suggestion looks promising.
sunrider

Posts: 17
Registered: 01/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 17-Nov-2009 19:24   in response to: cxx in response to: cxx
 
  Click to reply to this thread Reply
cxx wrote:
Hey there,

I just found a solution on that issue.

The omnibook-module from http://sourceforge.net/projects/omnibook/ actually does the trick.

Just open a terminal, become root and enter the following commands:

  1. cd /usr/local/src
  2. wget http://downloads.sourceforge.net/project/omnibook/omnibook%20kernel%20module/2.20070211/omnibook-2.20070211.tar.gz?use_mirror=sunet
  3. tar xvfz omnibook*
  4. cd omnibook
  5. make
  6. make install

Now the module is installed, we just need to activate it:

  1. depmod -a
  2. modprobe omnibook ectype=11

After issuing that command fan-control is working.

  1. cat "omnibook ectype=11">>/etc/modules

And this causes the module to be loaded on boot. This last step depends on your distribution, this may be set somewhere else if you don't use a debian-based one. You surely need the appropriate kernel-sources for you your distribution and a compiler for installing the module - on debian or similar installing the packages "linux-headers-2.6-your running kernel" and "build-essential" should be enough.
I've tried this solution but there was some compilation error. I'm using 2.6.32rc7 kernel.
sunrider

Posts: 17
Registered: 01/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 17-Nov-2009 19:26   in response to: cxx in response to: cxx
 
  Click to reply to this thread Reply
Well, I've just downloaded the svn trunk and the compilation went well. But after doing :
sudo modprobe omnibook ectype=11
then
sudo modprobe omnibook fan=1
sudo modprobe omnibook fan_policy=1

The fan is still spinning at full speed...but at least, I've got :
cat /proc/omnibook/fan
Fan is on (level 26)

And I can't change the value with echo "value" > fan...

Message was edited by: sunrider

Message was edited by: sunrider
sunrider

Posts: 17
Registered: 01/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 24-Nov-2009 09:09   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
Up ;)
tdassler

Posts: 6
Registered: 10/10/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 26-Nov-2009 16:35   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
cat /proc/omnibook/fan
Fan is off

It alwas shows as off, regardless of the spin state. But this is not what matters. What does is that the fan now switches as it should.
tdassler

Posts: 6
Registered: 10/10/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 26-Nov-2009 16:49   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
I should also explain how I got the module compiled and autoloaded:

wget ftp5.gwdg.de/pub/opensuse/update/11.1/rpm/src/omnibook-20080627-1.1.6.src.rpm
rpm2cpio omnibook-20080627-1.1.6.src.rpm | cpio -i omnibook-2.20080627.tar.bz2

untar, then get patch from
http://sourceforge.net/tracker/index.php?func=detail&aid=2785886&group_id=174260&atid=868544

cd omnibook-20080627
patch -p0 < ../path/to/patch
make ; make install ; depmod -a

nano /etc/modprobe.d/omnibook
put this in:
options omnibook ectype=11 fan=1 fan_policy=1

modprobe omnibook
sunrider

Posts: 17
Registered: 01/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 26-Nov-2009 17:28   in response to: tdassler in response to: tdassler
 
  Click to reply to this thread Reply
What about omnibook svn version without the patch ? Is it expected to work ?
Actually an echo "4" > lcd is working...but I can't do anything on /proc/omnibook/fan....

I've also loaded omnibook with ectype=11 and fan=1 and fan_policy=1
cxx

Posts: 2
Registered: 15/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 29-Nov-2009 07:58   in response to: sunrider in response to: sunrider
 
  Click to reply to this thread Reply
Hello,

I think my last reply has not been approved - if this happens again, this will be my last post here.

Did you try Kernel 2.6.31? 2.6.32 has not been released yet, maybe there are some unresolved issues regarding that problem.

I did not need to patch anything to get this working.
sunrider

Posts: 17
Registered: 01/11/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 30-Nov-2009 18:07   in response to: cxx in response to: cxx
 
  Click to reply to this thread Reply
Yeah, same thing with 2.6.31 ;)
tdassler

Posts: 6
Registered: 10/10/09
Re: Satellite L300-1AQ - Fan not switching properly under Linux
Posted: 01-Dec-2009 13:30   in response to: sunrider in response to: sunrider
 
  Click to reply to this thread Reply
sunrider,
I have not tried omnibook from SVN. Do you have a link?
Thanks,
T
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software