Welcome to the Toshiba Support Forum, created for customers and enthusiasts to share knowledge, solve problems and discuss technology. To join the discussion, please login or register.
Thread:
Screw is missing after service and can't find the right display driver
Search Forum Boards
advanced searchadvanced search user searchuser search
Forum Content Key
Unread Indicates new content items added
Updated Indicates content items updated
Read Indicates content items read
Thread Locked This thread is locked - replies are not allowed.


This question is answered.


Permlink Replies: 5 - Pages: 1 - Last Post: 25-Mar-2010 10:06 Last Post By: Xardas
sayhi80

Posts: 11
Registered: 12/03/10
Screw is missing after service and can't find the right display driver
Posted: 23-Mar-2010 00:57
 
Last week, I complained about the mic's low level and I sent it to Toshiba mobile care in Adelaide. Yesterday, they sent it back.

Problem one:

I checked the laptop carefully and found out there's one screw missing near the wireless switch. (The screw type should be F6.5). Could Toshiba sent me that screw so that I can put that back on?

problem two:

The problem my laptop had last week was low level of the mic. I adjusted the mic level to 100% and boost to 0%, I can't get any thing from the mic indicator by yelling to the mic.
Yesterday when I check the repaire report, it says "updated sound and video drivers, adjusted mic boost, replaced mic, updated bios, unit passed all diagnostics"

It worked well when I checked. But for some reason I need to re-install the laptop. After I re-installed the system, the same old problem came up again! Then I updated the bios, the audio drivers. According to the report, I should update the video driver too. I went to mytoshiba.com.au, entered the download page of the windows 7 for the P500, I couldn't find the right video driver for my laptop. Mine is "NVIDIA GeForce GT230M version=8,15,11,8642". The driver on the web page is "AMD Display Driver 8.634.1-090729a-086065C-Toshiba".

I downloaded it anyway and tried to install this video driver. After the extraction completed, I checked the basic information of this computer. The bios and the audio drivers are updated, but the video driver is still the same and the low mic level problem is still the same.

Last week I called twice the telephone support, more than an hours waiting, spent so much time on the forum, made an very ugly box and sent the laptop to the mobile center, my laptop was opened and changed part and sent back to me. After all this, I still got the same laptop with the same problem and now is missing a screw!!

I appreciate the work the technicians did. They did fix the problem. But I don't want to send the laptop to them every time after I re-install the system. So please tell me how to fix it.
PinkPanther

Posts: 1,806
Registered: 01/10/09
Re: Screw is missing after service and can't find the right display driver
Posted: 23-Mar-2010 08:33   in response to: sayhi80 in response to: sayhi80
 
Hi sayhi80,

I doubt that Toshiba can send you this screw but you should contact the authorized service provider again. I’m pretty sure that they can send you the missing screw and you can install it yourself. This should take only few seconds.

Regarding your question about the display driver: Which graphic card you have exactly? If you have a nVidia card, you can’t install the AMD Display Driver.
Furthermore it would be interesting to know which notebook you have exactly. Maybe you can post the exact model number.

Normally are all drivers placed on the Toshiba page…
sayhi80

Posts: 11
Registered: 12/03/10
Re: Screw is missing after service and can't find the right display driver
Posted: 23-Mar-2010 11:20   in response to: PinkPanther in response to: PinkPanther
 
Thank you for the reply. Here are the information of my laptop, I copy them exactly from the "Toshiba PC Diagnostic Tool - Basic information"

Model Name: Satellite P500
Part Number: PSPG8A-020004
Serial Number: Y9152230W
OS version: Microsoft Windows 7 Home Premium 6.1.7600
BIOS Version: V3.10
CPU: Intel(R) Core(TM)2 Duo CPU P8800@2.66GHz
Physical Memory: 4096MB RAM
Hard Disk Capacity: 626,750,644,224Byte 583.707GB
Hard Disk Free Space Capacity: 578,957,660,160Byte 539.196GB
Video: NVIDIA GeForce GT 230M version=8.15.11.8642
Screen Resolution: 1680X945 Pixels
Color Quality: True Color (32 Bit)
Sound: NVIDIA High Definition Audio version=1.0.0.55
NVIDIA High Definition Audio version=1.0.0.55
NVIDIA High Definition Audio version=1.0.0.55
NVIDIA High Definition Audio version=1.0.0.55
Conexant Pebble High Definition SmartAudio version=4.98.8.61
Network: Atheros AR8131PCI-E Gigabit Ethernet Controller (NDIS 6.20) version=......
Modem: None
Internet Explorer: 8.0.7600.16385
IDE Device: Hitachi HTS545032B9A300
TOSHIBA MK3263GSX
MATSHITA BD-CMB UJ141ES FW version=1.00

So, I'm pretty sure that the video driver of my laptop is not on the Toshiba page or not on the right page. I noticed that they update the pages after I complained about I couldn't find the drivers of my laptop for windows 7. I very appreciate it.
Xardas

Posts: 3,144
Registered: 02/10/09
Re: Screw is missing after service and can't find the right display driver
Posted: 23-Mar-2010 12:33   in response to: sayhi80 in response to: sayhi80
 
Hi sayhi80,

I don’t know why the Toshiba website shows another driver but in this case I would recommend checking the European page. There you can download the nVidia display driver for Windows 7 64bit:

http://eu.computers.toshiba-europe.com => Support & Downloads => Download Drivers
Notebook > Satellite > Satellite P Series > Satellite P500 > PSPG8E

Check this!!!
sayhi80

Posts: 11
Registered: 12/03/10
Re: Screw is missing after service and can't find the right display driver
Posted: 25-Mar-2010 08:47   in response to: Xardas in response to: Xardas
 
I couldn't find my model anywhere else except the web site.

I brought it back to Toshiba mobile care center, problem solved. The technician told me that the newest driver he installed and solved the problem in my laptop hasn't been released yet and he can't give it to me. So I backed up my system after the service.

Thank you every one.
Xardas

Posts: 3,144
Registered: 02/10/09
Re: Screw is missing after service and can't find the right display driver
Posted: 25-Mar-2010 10:06   in response to: sayhi80 in response to: sayhi80
 
GREAT!!!

Backup is always a good choice, mate. Now you can enjoy your notebook! :)
Legend
Master: 700 + pts
Scholar: 300 - 699 pts
Aficionado: 150 - 299 pts
Enthusiast: 50 - 149 pts
Beginner: 0 - 49 pts
Helpful Answer (5 pts)
Correct Answer (10 pts)

Point your RSS reader here for a feed of the latest messages in all forums


Copyright © 1995-2011 TOSHIBA Corporation, All Rights Reserved
Powered by Jive Software